A Magyar Jachtos appja

A Magyar Jachtos appja

kézikönyv, útmutató

A MaJa app "TORNADO" verziójához

Created with the Personal Edition of HelpNDoc: Free help authoring tool

Készítette Vendel-Mohay István 2020-ban. Minden jog fenntartva.


Bevezetés

A Magyar Jachtos appja ››

Bevezetés

Te is mindig átugrod a bevezetőt? Akkor nem bírlak visszatartani én sem, csapj a közepébe, csak majd később térj ide vissza, ez is érdekes!

Created with the Personal Edition of HelpNDoc: Free EPub producer


Az alkotóról

A Magyar Jachtos appja ›› Bevezetés ››

Az alkotóról

Kedves felhasználó!

Mindig csodáltam a vizisportokat, és lefőképpen a vitorlázást. Remélem ezzel az applikációval egy hasznos kis eszközt adok a kezedbe, amivel még közelebb hozhatlak, hisz ahogy az egyik oktatóm, Kocka mondta:

"Lényeg, hogy jó levegőn van a gyerek!"

Vendel-Mohay István - a MaJa készítője.

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Újdonságok

A Magyar Jachtos appja ›› Bevezetés ››

Újdonságok

Mivel az app első verziója most készült el, gyakorlatilag minden újdonság.

Ha a Balaton Pilot című kiadványhoz viszonyítunk, akkor az újdonságok az applikáció elektronikus lényegéből adódnak:

- A megadott telefonszámok melletti ikonra kattintva egyből felhívhatjuk a kontakt személyt.

- A megadott koordinátát megcélozhatjuk.

- A hajónk adatáról is kapunk adatokat.

- Van egy Man-Over-Board azaz Ember a vízben funkciónk, ami nem jelent valódi riasztást, így koordináták megjegyzésére is felhasználható.

Created with the Personal Edition of HelpNDoc: Produce Kindle eBooks easily


Az app használata

A Magyar Jachtos appja ››

Az app használata

Bár próbáltam a legnagyobb egyszerűségre, és a kis erőforrásigényre törekedni, jobb a minél nagyobb biztonság érdekében az app képességeit megismerni.

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Fontos tudnivalók

A Magyar Jachtos appja ›› Az app használata ››

Fontos tudnivalók

"A gépek az okos embert okosabbá, a butát még butábbá teszik" - Vass Tibor tanára.

Elsőnek itt is megjegyezném, hogy semmiféle felelősséget nem vállalok az app használatából eredő bármilyen kárért, balesetért. Azt, hogy a kapitány felelőssége egyetemleges, semmilyen technikai eszköz nem változtatja meg.

A legjobb tudásom szerint programoztam az appot, hogy minél használhatóbb és biztonságosabb legyen, de soha ne bízzunk meg egy gépben!

Itt is kiemelném, hogy a legtöbb telefon GPS helymeghatározása erősen támaszkodik a GSM és a WiFi hálózatra. A hiba 1 méteres szórástól akár 40 méterig is emelkedhet nyílt területen. Zárt területen, pl. esetlegesen a hajó kajütben enné még rosszabb eredményt kaphatunk. Ez az autós navigációnál tökéletes, viszont ebben a formában nem ad elvárható pontosságot. Kikötőkre kormányzáshoz megfelelő, viszont a vízből mentésnél csak másodlagos segédeszköz lehet, kiegészítő más, pontosabb eszköz mellett.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Telepítés, eltávolítás

Telepítés, eltávolítás

Az app egyelőre nem kerül fel semmilyen hivatalos áruházba, mert ingyenes volta miatt nem akarok még pénzt is ráfordítani, és a hivatalos közzététel előtt még sok gyakorlati tesztelésre van szükség.

A telepítéshez szükség van Android rendszereken egy APK kiterjesztésű állományra, ez jelenleg a maja.apk

Bár nem zárom ki a szabad másolás lehetőségét, azért igyekezzetek közvetlenül tőlem, a legújabb változatot beszerezni!

Az apphoz jár még ez a dokumentáció, többféle formátumra fordítva.

Bárhogy is szereztük be az APK-t, a telefonon egy fájlkezelőből kezdjük meg a telepítést. Figyelmeztetni fog a külső forrásból származó appok veszélyeire, de ha tőlem, vagy megbízható ismerőstől vannak a fájlok, akkor ezt a figyelmeztetést figyelmen kívül hagyhatjuk.

Bizonyos rendszerek alapból nem engedik meg a külső forrásból származó applikációk telepítését. Próbáljuk az adott Android változtat dokumentációjának megfelelően megadni a kivételt.

Bizonyos Android verzióknál csak az Alkalmazások menübe kerül be, az operációs rendszer szokásos módszereivel - pl. koppintás helyett hosszú ideig nyomva tartjuk az ikont - másolatot készít a fő képernyők egyikére.

Első indításkor - bár telepítéskor nem kért engedélyt - utólagosan engedélyt kér, amikor először használni akarja a gps-t.

Adjuk meg az engedélyt, mert enélkül a koordinátánk 0° szélesség, 0° hosszúság lesz, és az app igen korlátozottan használható.

Eltávolítás az Android konkrét változatánál megszokott módon: például hosszan nyomva tartjuk az app ikonját, és a felajánlott törlésre kattintunk.

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator


Az egyes funkciók használata

Az egyes funkciók használata

Program indítás

Kattintsunk a MaJa ikonra.

A kezdő képernyőn mindig el kell fogadnunk a használati feltételt. Fontos, hogy ez is emlékeztessen rá, hogy a hajó kapitányának továbbra is felelősségteljesen kell cselekednie.

Funkciók: a főmenü

Ez a kiindulási ablak.

A figyelmeztetés elfogadása után a főmenübe jutunk, ahol:

- kiválaszhatunk egy menüpontot,

- beléphetünk a "MOB - ember a vízben!" funkcióba.

A "MaJa" logó ennél az oldalnál csak díszítés, minden más oldalról ebbe a főmenü ablakba hoz vissza.

Objektumok listája: Kikötők, hajóállomások, sportegyesületek, üzletek

Ebben a listában láthatjuk:

- a saját, nyers, utoljára lekérdezett műholdas pozíciónkat,

- az egyes objektumok nevét, saját, és hozzánk viszonyított helyzetét.

Az objektumokat a műszerfalon meg tudjuk szűrni. Ha a listában túl sok, vagy túl kevés elem látható, állítsuk be régió és típus szerint a kijelzett objektumokat. Ha egyáltalán nincs kijelzett elem, akkor (jó esetben :) ) sikerült túlzottan megszűrni az adatokat.

Az objektumok nevét tartalmazó sávra kattintva bővebben megtekinthetjük a listaelemet:

A "MaJa" logó a főoldalra, a MOB gomb a jobb felső sarokban a "MOB - ember a vízben" oldalra visz.

Részletes adatok: a kiválasztott objektum adatai

A listából kiválasztott objektum adatait nézhetjük meg bővebben.

A lista fölött két gombot találunk, az egyikkel csak egy szintet, azaz az objektum listáig lépünk vissza, a másikkal pedig kijelölhetjük célnak, illetve levehetjük a célt az aktuálisan kijelzett objektumról.

A "MaJa" logó a főoldalra, a MOB gomb a jobb felső sarokban a "MOB - ember a vízben" oldalra visz.

Magyar hajósok: az arcképcsarnok

Itt egy szubijektív listát lehet találni ismert magyar hajósokról, és fontos helyekről. Sokkal több embert tettem volna a listába, de mivel nem érkezett több visszajelzés, kénytelen vagyok a saját hajós előéletemen keresztül utalni más, nekem fontos személyre.

A "MaJa" logó a főoldalra, a MOB gomb a jobb felső sarokban a "MOB - ember a vízben" oldalra visz.

Műszerfal: beállítások, mért adatok kijelzése

A gps koordináta időbeni változásából számolt navigációt segítő adatok. Nem használja a készülékben esetleg meglévő mágneses iránytűt.

Három csoportot találunk:

A hajó adatai - (ezek valójában az appot futtató készülékre vonatkozó adatok, ami jó esetben a hajón tartózkodik, és nem hagytuk a parton, vagy ejtettük bele a vízbe).

A cél adatai - itt csak akkor jelez ki bármit is, ha van kiválasztott cél. Ha van aktív MOB, akkor azé a prioritás, ha nincs, de van kiválasztott objektum, akkor az lesz a cél.

Az alábbi példában láthatóan egy kikötő ki van választva, de nincs aktív MOB koordináta.

A műszerfal már viszonylag pontos gps adatok esetén. Azért ilyen haladás/hiba aránynál el tudjuk képzelni, hogy mekkora lehet az irányok, iránylatok, orszögek pontatlansága!

Beállítások: szűrési lehetőségek

A beállításoknál egyelőre két szűrőt lehet beállítani a kijelzett régió és a kijelzett objektumok típusa szerint:

A "MaJa" logó a főoldalra, a MOB gomb a jobb felső sarokban a "MOB - ember a vízben" oldalra visz.

MoB: ember a vízben!

Mentést támogató funkció...

De A MaJa NEM életmentő eszköz!

Ennél a funkciónál két dolgot kell figyelembe venni:

- Ne adjon hamis biztonságérzetet! A legjobb tudásom szerint készítettem, de így sem annyira megbízható, mint egy életmentő eszköztől elvárható.

- A funkció úgy lett kialakítva, hogy kétség nélkül merjük használni.

A MOB nem küld vészjelzést, ellenben a koordinátát a funkció behívásakor automatikusan rögzíti, hogy a vízbe került ember koordinátáját minél gyorsabban, és pontosabban rögzíthessük.

A rögzített pozíciót az aktiválással célként adjuk meg, és biztonsági okokból csak inaktiválni lehet, törölni nem.

Ha belépünk a MOB - ember a vízben oldalra, és nincs aktivált pozíció, akkor a rendszer hozzáadja az aktuális pozíciót inaktívként, mint a bal oldali képen látszik. A jobb oldalon, a következő korábbi elemet aktiválva, a 15:27-kor létrehozott elem már aktívként jelenik meg. Ezt utána deaktiválhatjuk, de ha másikat aktiválunk, akkor arra ugrik át az aktivált állapot, mert csak egy cél lehet aktív. Utána elhagyhatjuk az oldalt, az aktív aktív marad, valamint a műszerfalon a célobjektummá a MOB cél válik.

Mivel nem ad vészjelzést, még a szárazföldön, biztonságban próbáljuk ki, hogy mire képes, és mire nem!

Másodlagos felhasználás saját koordináták rögzítése, amiből az utolsó tizet jegyzi meg. Ha nem akarjuk, hogy kifussanak, akkor aktiváljuk valamelyiküket, ekkor a funkcióba belépéskor nem kerül újabb koordináta rögzítésre.

A "MaJa" logó a főoldalra visz.

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Tippek, trükkök

Tippek, trükkök.

Teszteljük szárazon az appot, hogy megismerjük a képességeit!

Ha a GPS-re akarunk támaszkodni, várjunk meg úgy 10 ciklust, azaz kb 30 másodpercet, hogy a lehető legpontosabbá váljon a mérés!

Tartsuk a készüléket száraz, vízbeeséstől védett, de olyan helyen, ahol az égboltból minél nagyobb szögben rálát!

A pontosságot tesztelhetjük olyan helyen, aminek pontosan ismerjük a netről a koordinátáját és az útvonalnunknak az irányait.

Created with the Personal Edition of HelpNDoc: Produce online help for Qt applications


Ismert problémák

Ismert problémák

Nem úgy működnek a "vissza" gombok, ahogy elvárható lenne. Kettőt lépnek vissza.

A GPS nem működik minden körülmények között tökéletesen, ezért mindig figyeljünk a környezetünkre és a hibahatár szerinti mértékben legyünk kritikusak!

Minden erőmmel azon leszek, hogy ezeket a problémákat minél jobban kiküszöböljem, de mindkettő olyan, hogy figyelembe véve nem okoznak számottevő problémát.

Ésszel! Mindig ellenőrizzük a gépek helyes működését, csak támogassanak a döntésekben, ne döntsenek helyettünk!

A Flutter, amiben az egész rendszer készült egy 3 éves programnyelv, és folyamatosan fejlődik. Nagyon használható, viszont még egyáltalán nem kiforrott, bár a Google fejleszti, ahol az Android is készül, előfordulhatnak stabilitási problémák.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Lehetséges fejlesztési irányok

Lehetséges fejlesztési irányok

Számtalan ötletem van, amik közül azt veszem előre, ami a felhasználók számára legkedvesebb lenne.

NEM fog belekerülni térkép, mert a legtöbb hasonló app rettentő bonyolulttá, nehezebben áttekinthetővé vált az oprendszerből módosítások nélkül beemelt gyári térképmodultól. Saját elképzelésem szerint a térkép egy másik eszközön érdemes futtatni a térképet.

Végig azt az irányt akarom követni, hogy a MaJa minél több funkciója elérhető legyen akkor is, ha nincs épp elérhető internet.

- Pályák bójáinak felrakását segítő navigáció.

- Érkezés várható idejének laza becslése.

- Versenyek bójahelyzetének előzetes letöltése.

- Csekklisták, regionális és általános üzenetek betöltése, klubokon belüli kapcsolattartás funkciói.

- Flottahajózást támogató eszközök (ehhez mondjuk pont kell a GPS, de még a funkciót is ki kell találnom pontosan).

- Szponzori információk hozzáadása.

- Objektumok többféle szempont szerinti rendezése.

- Kiterjesztett tudású változatok elkészítése.

- IOS változat elkészítése.

A Maja alapváltozata ingyenes, és az is marad, viszont időnk arra van, amire szánunk. Ha szeretnéd, hogy sok időt szánjak ennek elkészítésére, akkor támogatsz a munkámban.

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle